Search Help

The Next Gen mobile app and end of support for older apps

We no longer offer support for the Classic app. The good news is that our Next Gen app is available for download instead.

The Next Gen app gives you more opportunities to personalize your experience and uses our new 'Aurora' graphics engine for better visuals.

What are the requirements needed for the Next Gen app?

  • Operating system: Android 5 / iOS 11 or higher
  • Screen resolution: 800x480 or better
  • Location services: On

How do I update to the Next Gen app?

Once your device meets the requirements above, uninstall the Classic app. Then, download our latest app from our website, Google Play, or the Apple App Store.

Feedback

Did this article answer your question?

Related Help Articles